CCS install problem on Microsoft SQL 2014

Document ID : KB000045606
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem :

During installation of CCS with a database on Microsoft SQL 2014, error "The installation of 'CA Common Services (CCS)' failed. Return code 1" appears.

 

Untitled.jpg

 

In %TEMP%\TRC_Inst2_ITRM.log following error appears :

 

08/11/16 21:10:51.0367|2744:| CCSProxyHandler: CCS validation failed because: The SQL Server edition that is installed on COMPUTERNAME is not supported. You must choose another server. Refer to Unicenter documentation for more information regarding system requirements.
08/11/16 21:10:51.0414|2744:| CCSProxyHandler: UCS_Setup_ValidateData(UCSWRVDBAS_SERVER_VALID): FAILED
08/11/16 21:10:51.0414|2744:| CCSProxyHandler: CCS validation failed because: An unsupported version or Service Pack level of Microsoft SQL Server is installed on JY-SQL2014.  Version of Microsoft SQL Server must be either '2000' with at least Service Pack 4 or '2005'.
08/11/16 21:10:51.0429|2744:| CCSProxyHandler: UCS_Setup_ValidateData(UCSCOMMAIN_ALL_VALID): FAILED
08/11/16 21:10:51.0429|2744:| CCSProxyHandler: CCS validation failed because: An unsupported version or Service Pack level of Microsoft SQL Server is installed on JY-SQL2014.  Version of Microsoft SQL Server must be either '2000' with at least Service Pack 4 or '2005'.
08/11/16 21:10:51.0461|2744:|CCSProxyInterface PrepareData(): process complete: return code: <UCSERR_VALIDATION> lasterr:<An unsupported version or Service Pack level of Microsoft SQL Server is installed on COMPUTERNAME.  Version of Microsoft SQL Server must be either '2000' with at least Service Pack 4 or '2005'.>
08/11/16 21:10:51.0461|2744:|CCSProxyInterface RunCCS: PrepareData() FAILED. Unable to continue...Skipping install
08/11/16 21:10:51.0476|2744:| CCSProxyHandler: requestType <2>
08/11/16 21:10:51.0476|2744:| CCSProxyHandler: Calling UCS_Setup_CloseSession() UcsSessionHandle:<01012560> ThreadID:<1408>
08/11/16 21:10:51.0492|2744:|CCSProxyInterface CloseSession(): process complete: return code:<UCSERR_VALIDATION>
 

  

Environment:  

CA ITCM 12.9, 14.0 or higher
Microsoft SQL 2014 or higher
 
 
 

Workaround :

Unfortunately CCS is not supported on SQL 2014.
 
CCS is in a stabilized state since 2014. So this component does not support new OS and SQL Server versions. 
CCS could not be installed on SQL Server 2014. 
 
Some CCS components have already been introduced in ITCM features. 
But some CCS components (like CCS discovery of unmanaged assets) are not yet implemented in ITCM. 
 
Whilst we added support for SQL 2014 in Client Automation 12.9 and 14.0 this does not extend to CCS.
 
 
Here is an extract of 12.9 release notes section on Removed and Discontinued Features :
 
 
"CCS Event Management, Calendaring, Discovery (Common & Continuous), World View and High Availability Service functionalities are not supported on the newer Operating System and Database platforms that was being supported from 12.8 onward. 
 
We are targeting the replacement of key portions of CCS functionality in CA Client Automation 12.9 and future releases. 
Until the Replacement Plan is complete, CA Client Automation Enterprise and Domain Managers may be supported on a broader range of platforms than that is offered by CCS (such as Windows Server 2012 R2). In such scenarios, CA Client Automation may continue to be used without the functionality offered by CCS. Alternatively, CCS may still be installed on its supported platforms."
 
 
 
In order to use CCS Discovery, a workaround could be to install another DOMAIN ITCM on SQL 2008 or 2012 with CSS. 
Then do the CCS Discovery from this DOMAIN. 
And once ITCM Agents are installed using this DOMAIN, move the agents to the first DOMAIN (one with SQL Server 2014)