CCI Errors after Putting On New Build CA OM Web Viewer 12.1

Document ID : KB000122777
Last Modified Date : 28/12/2018
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Issue:

We put on a new build and are getting CCI errors that look to be serious

Error: CCI.IssueRequest fails with result code: REQUEST_CCI_CONV_FAILURE

and in the DRAS log:

CAHFMTK013E CCI send for conid(2) failed, status = 8, reason = 32
 

Cause:
Some requests can take 4 or 5 minutes or more to complete, such as, but not limited to, index name-value requests for matching reports over a multi year span.
Resolution:
Increasing the Remote Timeout value for Web Viewer from 60 to 900 seconds resolved the problem.

Follow these steps to set the remote timeout value:

  1. From the Administration tab, click the Preferences subtab:
  2. Click the General Preferences link.
  3. In the Timeout section, set the options as follows:
    1. Locate the Remote Connection timeout option.
    2. Enter the number of seconds that can lapse. 
      CA OM Web Viewer-to-mainframe connection times out after this many seconds.
  4. Click Update at the top right of the pane.
    The timeout values are updated.
Additional Information:
Remote Connection Timeout
This is the connection timeout used when CA OM Web Viewer is communicating with the Mainframe repository systems through CA DRAS. This setting specifies how long CA OM Web Viewer should wait for a slow responding Mainframe or Repository or a CCI connection before generating a timeout message.