Catalog Service Request and attaching a file, Error: Access denied or a document with the same name already exists

Document ID : KB000004519
Last Modified Date : 14/02/2018
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Issue:

When creating a Catalog Service Request and attaching a file, on Submission you may get an error message stating:

"Error Uploading file(s): Access denied or a document with the same name already exists.

Environment:
Windows
Cause:

Incorrect File Type Signatures

Resolution:

1. Locate the 'FileTypeSignatures.properties' file in %USM_HOME%\view\webapps\usm\config\ folder.  

2. Update file to remove the spaces between each pair of digits: 

Example:

- FROM:

exe=4D 5A
class=CA FE BA BE
zip,xslx,jar=50 4B 03 04,50 4B 05 06 

- TO:

exe=4D5A 
class=CAFEBABE 
zip,xslx,jar=504B0304,504B0506 

3. Clear and Restart the Catalog services:

- Stop the CA Service Catalog services(Accounting and Catalog)
- Empty/clear the %USM_HOME%\view\translets folder
- (re)move the %USM_HOME%\logs\*.log files
- Clear the browser-cache
- Start the CA Service Catalog services(Accounting and Catalog)