Cannot upload a JMeter script to ASM. Receiving error "Your script contains unsupported sampler commands. These unsupported commands were found in your script: BeanShell Sampler."

Document ID : KB000016829
Last Modified Date : 14/02/2018
Show Technical Document Details
Question:

  On creating some advanced monitors with Jmeter scripts, receiving an alert informing me of the following: 

 "Your script contains unsupported sampler commands. These unsupported commands were found in your script: BeanShell Sampler. Please disable or remove them before uploading. "

 Why are these commands invalid and how can I fix them?

Environment:
Current ASM release
Answer:

The BeanShell sampler is not supported due to security concerns.  While the BeanShell Sampler itself is not supported, note that the BeanShell pre/post processors and assertions are supported.

See the below for more information.

JMeter samplers blacklisted on ASM