Cannot save visual flows to this level error in Agile Designer

Document ID : KB000006559
Last Modified Date : 14/02/2018
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Issue:

I am receiving the following error when trying to save my Agile Designer flow to Test Data Manager:

Cannot save visual flows to this level. Please select a level which allows saving visual flows (such levels are marked in green). 

cannot save flow to level.PNG

I have tried different permission settings and tried using an Administrator account, but I am still having the same issue. 

Environment:
CA Agile Requirements Designer (ARD)- Agile Designer
Cause:

The reason you are seeing this error message is because you cannot save a flow to a Version level. If you do not have anything else showing besides the project and version folder, you will need to create at least a Data Group under that project to save your flow to. Make sure to have the Data Group/Set/Pool as type 'Agile Designer' and set to be 'Available on Demand'. 

Resolution:

First you need to make sure you have a Data Group, Data Set, and Data Pool created in Datamaker for the Project you are trying to save to. Follow the steps in this documentation on how to create a project: https://docops.ca.com/ca-test-data-manager/4-1/en/provisioning-test-data/configure-test-data-reservation-service/configure-form-based-test-data-reservation-service/test-matching-and-re-matching/create-project-in-datamaker 


Right click on your Data Pool (or whichever group you are saving your flows to) and choose the 'Properties' option.

data pool properties option.png

 

In your 'Edit' window, do the following:

- Check the box for 'Available on demand'
- Under the 'Type' dropdown, choose the 'Agile Designer' option.
- Click the Save icon to save your changes. 

Once this has been done in Datamaker, you will be able to see the hierarchy in ARD and be able to access/save to without error.

type agile designer in dp properties.PNG

 

In Agile Designer, try to save your flow to Datamaker again. You should see the Data Group/Set/Pool and be able to save successfully. 

save as to repo ard.png

save flow as ard1.PNG

save success.PNG

Additional Information:

If you experience any further issues, please open a support case on https://support.ca.com/irj/portal/newhome or call support at one of these numbers https://www.ca.com/us/services-support/ca-support/contact-support.html.

 

Below is documentation on how to use ARD with TDM and TDoD: