Cannot open the CA Patch Manager(UPM) login screen but can login to the Web Admin Console (WAC).

Document ID : KB000026509
Last Modified Date : 14/02/2018
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Problem: 

Users cannot open the UPM login screen even though they are able to login using the Web Admin Console (WAC).
This can happen after an upgrade or with a new install.

Environment:  

CA Client Automation - All Versions

Patch Manager - All Version 

 

Cause :

The problem may be in one of the CA Client Automation based configuration files.

The files are located in the following path by default:     ...\CA\DSM\Web Console\jakarta

The three critical files are:
        workers.properties
        isapi_redirect.properties
        uriworkermap.properties

Look at the uriworkermap.properties file which should contain the following:
      /wac/*=ajp13w
      /wac=ajp13w
      /AMS/*=ajp13w
      /AMS=ajp13w
     /upm/*=ajp13w
     /upm=ajp13w

The file cannot contain duplicate or incorrect entries as outlined in the example below:
     /wac/*=ajp13w
     /wac=ajp13w
     /AMS/*=ajp13w
     /AMS=ajp13w
     /upm/*=ajp13w
     /upm=ajp13w
     /upm/*=ajp13w
     /upm=ajp13w
     /upm/*=ajp13w
     /upm=ajp13w

This breaks the UPM login completely.

Resolution:

Removing the 2 sets of duplicate pairs in the above example corrects the problem immediately.

No recycle of services is required.