Cannot obfuscate the passwords in the jetty config xml.

Document ID : KB000005874
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

  This error is received:

 

"Unexpected token 'org.mortbay.jetty.security.Password' in expression or statement. CategoryInfo: ParserError: (:) [], ParentContainsErrorRecordException FullyQualifiedErrorId : UnexpectedToken" 

 when trying to obfuscate the passwords in the jetty config xml's as described by the Tech Doc TEC1974214

 

 and execute the following commands in windows Powershell: 

java -cp "C:\CA APM\Introscope10.1.0.15\product\enterprisemanager\configuration\org.eclipse.osgi\bundles\186\1\.cp\jetty-util-6.1.26.jar";"C:\CA APM\Introscope10.1.0.15\product\enterprisemanager\configuration\org.eclipse.osgi\bundles\186\1\.cp\jetty-6.1.25.jar" org.mortbay.jetty.security.Password <user> <password> 

 

Environment:
AMP 10.3Windows 2012 R2
Cause:

This is a compatibility issue with the Powershell environment 

Resolution:

The below  command must be executed in a Windows prompt command and not in a Powershell window.

Sample : 

C:\User\> java -cp "C:\CA APM\Introscope10.1.0.15\product\enterprisemanager\configuration\org.eclipse.osgi\bundles\186\1\.cp\jetty-util-6.1.26.jar";"C:\CA APM\Introscope10.1.0.15\product\enterprisemanager\configuration\org.eclipse.osgi\bundles\186\1\.cp\jetty-6.1.25.jar" org.mortbay.jetty.security.Password <user> <password> 

C:\User\>