Cannot make a TIM Fresh Install.

Document ID : KB000031335
Last Modified Date : 14/02/2018
Show Technical Document Details

 

Issue:

Seeing the following errors when trying to make a fresh install:

"Warning: /opt/ca/CA/APM/tim is corrupt; unable to run deconfiguration"

and

"Error: Failed Dependencies: ApmPacket is needed by (installed) Tim (release)"

 

Environment: 

-Customer Experience Manager 9.7

Cause:

The issue may be that the APMPacket was already uninstalled and we are not able to remove the TIM completely. This can also happen when any configuration file is deleted from the opt/ca/CA/APM/tim directory and you need to repair the installation to access the APM CE (CEM) UI.

 

Resolution:

Open the TIM server and run:

1) rpm -e --justdb tim        (To remove TIM only from the RPM database.)
2) rm -Rf /opt/ca/CA/APM   (To remove all remaining installation files to ensure a clean system.)
3) rpm -U apmpackage tim (To ensure that APMPacket does not exist and fresh install can be done.)