Cannot copy Timesheet entry in New UI when using Investment specific Charge Codes

Document ID : KB000123035
Last Modified Date : 14/12/2018
Show Technical Document Details
Issue:
Cannot copy Timesheet entry in New UI when using Investment specific Charge Codes.

Steps to reproduce:
  1. Login to CA PPM as an admin user. 
  2. Go to Administration --> Project Management --> Settings. 
  3. Make sure that the "Enable Investment specific charge codes" is checked. 
  4. Go to Administration --> General Settings --> System Options. 
  5. Make sure that both "Activate new user experience" and "Activate Timesheet" options are checked. 
  6. Come back to the Home --> Projects page to view the Project List. 
  7. Create a new project. Fill up the mandatory fields and then click Save. 
  8. Click on the Properties drop-down and go to the "Charge Codes" subpage. This will be between the "Dependencies" and "Baseline" links. 
  9. Create a new Charge Code named "aaa1"and mark it "Open for time entry". 
  10. Go to the project setting page and set the "charge code" of the project as "aaa1". Save the changes. 
  11. Now to the Team - Staff page and add a resource under the project. 
  12. Create a new Task for the project and assign the resource in that task. 
  13. Set the charge code as "aaa1". 
  14. Also, make sure that the Task is marked "Open for time entry". 
  15. Save the changes. 
  16. Login as the resource who was added and assigned. 
  17. Go to the New UI timesheet link to fill up the timesheet. 
  18. Open the timesheet for the corresponding time period. 
  19. Add the task in the timesheet as a work item. 
  20. Click the options icon corresponding to the work item and select "copy". 

Expected Results: A new line will be created for the same task showing the charge code "aaa1"
Actual Results: An error appears as CMN-0009: Attribute 'Charge Code ID' has invalid Lookup Value '5001001'
Environment:
CA PPM 15.3
Cause:
Due to defect DE38977.
Resolution:
The defect has been fixed in CA PPM 15.6.0.64.