Cannot appear to connect after installing successfully APMSQL server on Linux.

Document ID : KB000006902
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

 I  have installed APMSQL server on Linux, but I am unable to connect.  I followed the documentation and started the APMSQL server, but cannot connect to it with a client.

 

 

Environment:
This behavior can happen when installing the APMSQL server on any compatible Linux type platform.
Cause:

This behavior is caused by a property located in the APMSqlServer.properties.  The property com.ca.apm.sqlserver.jdbcbind.address is set to localhost by default.  Though not wrong technically, it causes the APMSQL server to bind to the IP address mapped to localhost in the /etc/hosts file which is typically 127.0.0.1.   This situation prevents any connection coming to the APMSQL server on the actual hostname or IP address of the Linux system.

Resolution:

 To correct this behavior, add the IP address of the Linux system to the property com.ca.apm.sqlserver.jdbcbind.address located in the APMSqlServer.properties.  Once making the change, then a restart of the APMSQL server is required.

Additional Information:

 

 My APMSqlServer.properties setting com.ca.apm.sqlserver.em.webserver.port is not being picked up and stays set to the default setting of 8081.

https://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC1791947.html