Can you please confirm if the JRE shipped with One Click on Spectrum 10.x, always installs 64 bit version of JRE 1.8_31? Can that installer install 32 bit version depending on the OS of the machine?

Document ID : KB000057367
Last Modified Date : 14/02/2018
Show Technical Document Details

QUESTION:  Can you please confirm if the JRE shipped with OneClick on Spectrum 10.x, always installs 64 bit version of JRE 1.8_31? Can that installer install 32 bit version depending on the OS of the machine? 

 

ANSWER:  The JRE shipped with OneClick on Spectrum 10, always installs the 64 bit version of JRE 1.8_31. That installer CANNOT be changed to install 32 bit version depending on the OS of the machine. 

The following is from the "Frequently Asked Questions" section of the Spectrum 10.0 documentation at https://docops.ca.com//display/CASP10/Frequently+Asked+Questions: 

 

Q: Is 64 bit java jre client required? 

A: Yes, to take full advantage of the performance, 64 bit java jre version is needed to utilize CA Spectrum 10.0. If you are using a 32 bit client it may work, until more RAM is configured for the client by the Spectrum Administrator. At which point you may not even be able to launch your client if you are still using a 32 bit client. 

 

NOTE: Please keep in mind the 32 bit JRE is NOT officially supported for Spectrum 10.x. 

 

ADDITIONAL INFORMATION:  Please reference knowledge document  TEC1055973 "Is it possible to use 32 bit Java client for OneClick on Spectrum 10?".