Can we upgrade the version of Tomcat used by CABI 4.1 SP3?

Document ID : KB000015155
Last Modified Date : 14/02/2018
Show Technical Document Details
Question:

CABI 4.1 SP3 ships with Tomcat 7.0.32, and there are some vulnerabilities reported with this version, so how can the version of Tomcat which CABI uses be upgraded?

Answer:
SAP does not recommend upgrading Tomcat independently on a CABI server. Instead they suggest that the latest supported Service Pack be installed, which will automatically update Tomcat.

SP5 is the latest supported Service Pack available for CABI, which will update Tomcat to 7.0.55.

CABI 4.1 SP5 can be downloaded from the CA ftp site:

ftp://ftp.ca.com/caproducts/CABI/CABI-4.x/SP5/Windows

You need to download both files as one is the server side patch and the other the client tools patch. The documentation on applying SP5 can be found here:

https://docops.ca.com/display/CABI41SP5/How+to+Install+CABI+4.1+SP5+Patch

https://docops.ca.com/display/CABI41SP5/How+to+Install+CABI+4.1+SP5+Client+Tools+Patch