Can the need for the JCEUnlimited Strength files be disabled in CA Spectrum OneClick 9.4.2.1 or 10.0?

Document ID : KB000031390
Last Modified Date : 14/02/2018
Show Technical Document Details

Issue: 

In CA Spectrum 9.4.0 and above, when launching the CA Spectrum OneClick client, a window launches with a statement that JCE Unlimited Strength installation is required to run the OneClick client.  Is it possible to disable or change OneClick such that it will not require the additional installation of the JCE Unlimited Strength files?

Cause:  

This was done to support encryption for AES-256 and SHA-256.  Java 7 and Java 8 do not support 256 bit encryption out of the box, to use 256 bit encryption the use of JCE Unlimited Strength Jurisdiction Policy files must be installed.

Please refer to technical bulletin TEC616352 for further information as to why this was implemented.

Solution:  

Starting in 9.4.2.1 and also in 10.0 we have created patches PTF_9.4.2.1.134 for 9.4.2.1 and PTF_10.0.0.1 for 10.0 that will allow you to disable the need for clients to have the JCE Unlimited Strength policy file in place.  If a user is not able to install or chooses not to install the local_policy file, they cannot utilize/see/edit the 256 bit encrypted functionality which includes:

1. Saving the OneClick client logon password

2. Editing NCM configuration passwords

3. Editing SPM configuration passwords

These users can still launch the OneClick client whereas previously they could not.

Users that can install the local_policy file CAN:

1. Saving the OneClick client logon password

2. Editing NCM configuration passwords

3. Editing SPM configuration passwords

 

If you need either the  PTF_9.4.2.1.134 or the PTF_10.0.0.1 please open a support ticket and request them.

* Please note that these are bundle patches which contain a few other fixes in them, and you will benefit from those fixes as well.  Please read the release notes for the extra fixes that are included in the patches.

The need for the JCE Unlimited Strength Policy file has been removed in CA Spectrum version 10.1 and above.  In CA Spectrum 10.1 and above you can successfully run the OneClick java client without downloading/updating the local_policy.jar file.  All CA Spectrum OneClick functionality will work as it previously did.