Can't reach odataquery page after upgrading PM 3.1 to PM 3.5

Document ID : KB000071695
Last Modified Date : 22/02/2018
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Issue:
CA Performance Management was upgraded in a customer environment from 3.1 to 3.5.

The page http://DA_host:8581/odataquery is not available

Page gets redirected to: http://<CAPC_IP/Hostname>:8381/sso/sign-in.jsp?SsoProductCode=da&SsoRedirectUrl=http%3A%2F%2Fgjmlxpmdavh01%3A8581%2Fodataquery%2Findex.html

However the page times out.
Environment:
CA Performance Management 3.1 upgraded to 3.5
Cause:
Only two XML files should be existing in the following location /opt/CA/PerformanceCenter/sso/webapps/sso/configuration with .xml extension.

CADataAggregator.xml
CAPerformanceCenter.xml

There was one more file with .xml extension in the above location.

CADataAggregator-original.xml

 
Resolution:
CA Performance center SSO is extensible and the applications can put down their own xml file, sso knows how to talk to the xml files. It has no way of knowing that it should use CADataAggregator.xml or CADataAggragtor-original.xml however , the last one in wins.

Rename the backed up files without a .xml extension and then try accessing the URL again.

The change does not need a restart of the services.