Can't open older versions in the AWI Version Management

Document ID : KB000102757
Last Modified Date : 21/06/2018
Show Technical Document Details
Issue:
When trying to open 'old' versions of objects using the Version Management in the AWI, the following error message is displayed: 
Error during XRequest com.uc4.webui.communication.requests.OpenObjectAdapter 

The same objects can be opened using the deprecated Java User Interface. 

Here are some additional error messages that can be found in the AWI's log file: 
Caused by: com.uc4.communication.InternalException: Wrong LNR, expected: 2, is:3 
UC4Object JOBP.NEW.1.VER.20171205.114038, Type null: no sheets provided 
Environment:
Automic Web Interface 12.1.0
Resolution:
A correction for this issue is available on the following versions:
  • Automic Web Interface 12.2.0 - currently planned to be released end of June 2018.
  • Automic Web Interface 12.1.2 - Available
Please install one of the above listed versions or a higher version to resolve this issue.

Workaround:
Use the deprecated Java User Interface.