Can't execute call API on z/OS mainframe

Document ID : KB000103171
Last Modified Date : 25/06/2018
Show Technical Document Details
Issue:
The callAPI for z/OS times out and does not reach the Automation Engine activities window. However, the agent on the mainframe can run jobs with no issue.
Cause:
Likely this is an issue related to the tcp/ip stack. 
Resolution:
The following options can be used as a workaround:

- Upgrade the z/OS Agent to 12.1.2, and use UCCALL4 instead of UCXBM25C.

Alternatively, if agent upgrade is not an option, then please follow the steps below:

- Download the 12.1.2 z/OS Agent image, extract the files, and copy UCCALL4 and UCCALL4I to the installation load library.
- Replace the module name in JCL line:

UCCALL EXEC PGM=UCXBM25C,REGION=0M

with this one:

UCCALL EXEC PGM=UCCALL4,REGION=0M