Can not perform resume process run

Document ID : KB000004805
Last Modified Date : 14/02/2018
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Issue:

An action in a deployment was failed. Tried to resume the deployment to skip the action with failed_paused status, but it was not continued. Retried to resume, and then error was occurred like following.

Unexpected error on server [failed to resume job[id=98312]: Can not perform resume process run. A previous request, possibly invoked by other users, is currently performed: resume process run.] Please refer to server logs with timestamp [2016-11-30 11:53:25].

 

1. Attempt to resume at first time.

 

2. Wait for several minutes and retry to resume.

 

3. Error is occurred.

Cause:

While running the deployment, target agent was restarted or reboot by external Release Automation. The agent could not know the point to continue the deployment. Resume request could reach from Management Server to the agent, but the agent could not respond correct status. As a result, resume process was stalled actually, although it seems the resume process was running.

Resolution:

Don't stop Release Automation Agent service while running deployments or processes on the agent. Please wait for completion.
If you want to restart or reboot in a deployment, you can use [Restart Agent] or [Restart host] action. These action can continue the deployment after restart or reboot.