Can I run an older version DRAS with a newer repository (CA View or CA Dispatch)?

Document ID : KB000044091
Last Modified Date : 14/02/2018
Show Technical Document Details

Introduction: 

Can I run an older version DRAS with a newer repository (CA View, Dispatch or Bundl)?

Question: 

The question arose because the CA Dispatch r11.7 manual contains the following erroneous discussion:
"Upgrade Sequence:
You do not have to upgrade all products immediately when upgrading CA Dispatch to r11.7.
CA Dispatch r11.7 works with:

  • CA DRAS r11.5 and r11.6. You can upgrade CA DRAS to the current version at your convenience."

Again, this discussion is incorrect.

Environment:  

DRAS – z/OS

Answer: 

CA DRAS r11.7 is backward compatible where CA Dispatch is concerned. DRAS r11.7 will support Dispatch r11.7 as well as Dispatch r11.0. It is typically recommended you run the most current version of the CA repository and that the version of DRAS be the same as that of the repository.

Additional Information:

DRAS is NOT upwardly compatible where the repository version is concerned. A later version of DRAS will support accessing a lower version of a repository, but not visa versa. As this is true for all the supported report repositories, the same is true for CA View 12.x. For example, if the CA Output Management Web Viewer is accessing CA View 12.2, it must do so through CA DRAS 12.2.