Can I install the r11.3.6 SP4 client and run the r11.0 and r11.3.6 client in parallel?

Document ID : KB000045470
Last Modified Date : 14/02/2018
Show Technical Document Details

Question: 

I am upgrading a client from r11.0 SP5 to 11.3.6 SP4. All of the r11.0 SP5 machines have a client install. Can I install the 11.3.6 SP4 client and run the r11.0 and r11.3.6 client in parallel? 

 

Environment:

Workload Automation AE -11.0 SP5 and 11.3.6X

 

Answer:

It is possible to have a r11.0 client and 11.3.6 SP4 client in parallel. When you install the r11.3.6 SP4 client where the r11.0 SP5 client is present, it tries to upgrade the Csam version of r11.0 client (which breaks that client). To avoid this problem, our first recommendation would be to install the base version of r11.3.6 the client. When the r11.3.6 base client gets installed, it will lay down Csam version 2.2.8, which is compatible with the r11.0 client.

If you want to install the non-base client version (r11.3.6 SP4) in parallel to r11.0 SP5, edit the version.txt file of r11.0 SP5 client to 2.6.8 and then install r11.3.6 SP4 client. In this scenario, the r11.3.6 SP4 client will not upgrade the Csam version of r11.0 SP5 client and it will not break it.

The version.txt is located in the following directory: 

Windows: C:\Program Files (x86)\CA\SC\Csam\SockAdapter 

Linux: /opt/CA/SharedComponents/Csam/SockAdapter