Can I install Autosys 11.3 agent/client software on a machine which already has an existing AutoSys 4.5.x or 11.0 agent/client machine? Will it conflict with SSA?

Document ID : KB000049525
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

We are installing Autosys 11.3 client and agent software on a Windows machine which currently has Autosys already installed. Are there any possible Dylan Socket adapter conflicts?

Solution:

There will be no Dylan Socket adapter conflicts if the pre-existing version of AutoSys is 4.x. AutoSys 4.5.x does not use the Dylan Socket adapter, it connects to the AutoSys database directly via a locally configured db client.

The AutoSys 11.0 agent and client does use SSA, also know as Dylan Socket adapter or Csam. It will work with the newer version which is installed/updated as part of the AutoSys 11.3 install. The 11.3 client uses SSA. By default the agent does not. It uses plain sockets.

NOTE: When the subsequent installs are performed, make sure that the install directory for AutoSys is different than the pre-existing AutoSys install. So as not to over-write the existing software. Additionally the AUTOSERV values must be unique.