Can CA Datacom/DB be upgraded directly from version 12.0 to version 15.1?

Document ID : KB000039440
Last Modified Date : 14/02/2018
Show Technical Document Details

Question: 

Can CA Datacom/DB be upgraded directly from version 12.0 to version 15.1?

Answer: 

Because you are upgrading your existing environment, there are a number of changes to the Datadictionary throughout version 12.0 to prepare for version 14.0, and throughout version 14.0 to prepare for version 15.0. As a result, you will need to first upgrade to version 14.0 before 15.0.

You will need to review the README file for version 14.0 (RI37761 (DB 14.0 #1), "*README: STATUS OF CA DATACOM/DB/DD/DQ/SQL VERSION 14.0 Z/OS") to ensure you have the necessary maintenance on your version 12.0 system before starting the upgrade process. You will also be advised to run the DDSDCLM program to be sure that your Datadictionary is in the proper state to upgrade to version 14.0 - this is noted in the README file.

Likewise, you should review the version 15.0 README file (RI67375 (DB 15.0 #1), "* CA DATACOM/DB VERSION 15.0 Z/OS README") before starting that upgrade process.

You can then review the 15.1 README file as needed (RI86635 (DB 15.1 #1), “* CA DATACOM/DB INCREMENTAL RELEASE 15.1 Z/OS README”).    

As always, please contact CA Technologies support for CA Datacom if you have further questions.