Can a 2E developed program use run-time object Y2VLLSR from an earlier 2E release

Document ID : KB000045393
Last Modified Date : 14/02/2018
Show Technical Document Details

Introduction: 
The customer upgraded a 2E model from an earlier release to the latest release 8.7.

 

Questions: 

1. Can a program developed using 2E 8.7, call Y2VLLSR from an earlier release?
2. Can a program developed using an earlier release, call Y2VLLSR from 2E 8.7?

 

Answers: 

1. No, this is not advisable. You should always update the complete set of run-time objects to the latest release versions by running YDUPAPPOBJ.
2. Yes the run-time objects duplicated by YDUPAPPOBJ are always completely backwards compatible so will support programs generated from any previous release of 2E.