CAMM elements are duplicated incorrectly post upgrade in a multi-tenant environment

Document ID : KB000100405
Last Modified Date : 06/06/2018
Show Technical Document Details
Issue:
When reports are run it is sporadic whether or not data is present. This is due to the report not consistently picking one or the other of the duplicates. When the one without data is selected the result is an empty report.
Environment:
This is only seen for environments that upgrade to the r3.2 GA release from an older release.

Upgrades from older releases that skip the r3.2 GA install would not see this problem.

Systems that began life with the r3.2 GA or newer releases that are upgraded to newer releases would not see this problem. 
Cause:
After upgrading Data Aggregrator, during initial CAMM discovery in a multi-tenant environment, the Data Aggregator fails to migrate some attributes on the CAMM devices.  Without this migration, duplicate CAMM devices can be created.
Resolution:
Engineering modified the migration code to process all CAMM devices, regardless of tenant, during first CAMM discovery after Data Aggregator upgrade. This work can be tracked in defect DE325048.

This is resolved in the r3.2 November Monthly Update kit and the r3.5 GA release.

To ensure this problem is not seen, if the environment uses CAMM, do not upgrade to the r3.2 GA code base.

If upgrading from an older release and the process requires an r3.2 installation, use the r3.2 November Monthly Kit. This can be obtained upon request in a new support case.

If upgrading from an older release, if the option exists to bypass the r3.2 GA install and go directly to the r3.5 GA release take that path.