Calling API's in PAPI portal does not work

Document ID : KB000094097
Last Modified Date : 08/05/2018
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Issue:
If API is chosen in Portal API and you choose SUBMIT to check if you get a response, nothing shows up. There are no error messages either. 

User-added image
Cause:
The token end point is the tenant name. You must have a host file entry of this in the portal machine.
Resolution:
In the portal machine, open the /etc/hosts file. Create an entry with the portal ip and <tenant_name>.<domain-name.com> and <tenant_name>-ssg.<domain-name.com>

See the following section in documentation to update the hosts file
Edit Hosts File for Local Access

Example: If matse04 is your tenant then your entry would look like this in /etc/hosts

112.113.114.115       matse04-ssg.ca.com          matse04.ca.com