CallAPI error U00003308 Error while receiving error code 11

Document ID : KB000095467
Last Modified Date : 15/05/2018
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Issue:
A CallAPI for Unix is installed on a new server. A script is ran using the CallAPI and get an error:

U00003308 Error while receiving (error code '11'). The connection '10.152.224.78:2218' was terminated.

Investigation
1. Working CallAPI agent is installed in the same box as the non-production Automation Engine.  
Result:  This works because it doesn't have to go through many hops.
2. Non-working CallAPI agent installed in a different server.
Result:  This gets blocked because it has to go through 8 different hops before it can connect to the non-production Automation Engine.
3. A Windows CallAPI is installed on a user's local machine.
Result:  This works because it only went through 2 hops before connecting to the non-production Automation Engine.
4. Connect the non-working CallAPI agent to the production Automation Engine.
Result:  This works because it only had to go through 3 hops before it connected.
 
Cause:
The issue is not with the CallAPI agent, but with the network connection.
Resolution:
From the command line, execute this command:
traceroute <AE_server_name>  -- for Unix
tracert <AE_server_name>  --  for Windows

Work with the Network Administrator and provide the data to narrow down which hops are causing the blockage from the Non-working CallAPI server to Automation Engine.