Caf Stops working and a "Initialisation Failed" message occurs when attempted to run either a Caf Start or Caf Status.

Document ID : KB000045484
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem: 

ITCM Domain Manager is running in High Availability environment and its on Active node.It was working fine however when the common components folders are placed in a shared drive and it gets disconnected for whatever reasons, Caf Status or Caf Start " Initialisation Failed " message when we run  caf status or caf start 1.1.jpg

Try to set the logs in detail mode command also failed with " Can't Get or create the common store directory " 

Solution: 

Troubleshooting Steps : See if you have below Error's 

1. Check TRC_CF_CAF_Service_0.log

  ERROR  | GetCommonStoreDir(): DSM data directory does not exist!

  ERROR  | InitDirectStoreAccess(): Can't determine the common store location. Error: CCNF_CANT_GET_COMSTORE_LOC.

ERROR  | StoreAccess(): Can't initialize direct store access

|ERROR  | GetParameterValue(): Can't access store! Error: CCNF_CANT_GET_COMSTORE_LOC

ERROR  | ### AcquireReplyBlock(): factory request timeout ###

ERROR  | ### Send(): Can't initialize messaging! (206) ###

ERROR  | GetCommonStoreDir(): DSM data directory does not exist!

ERROR  | CCNF Agent: Can't determine the common store location. 

ERROR  | StoreAccess(): Can't initialize direct store access 

ERROR  |GetParameterValue(): Can't access store! Error: CCNF_CANT_GET_COMSTORE_LOC

ERROR  | The configuration component has failed its startup test and returned: 

Ccnf error code: 10: CCNF_PARAMSECTION_NOT_FOUND: can't find any plugins

ERROR  | CFUtils::raiseEvent: event 13 (CAFEVENT_ERROR) raised: The configuration component has failed its startup test and returned: 

Ccnf error code: 10: CCNF_PARAMSECTION_NOT_FOUND: can't find any plugins  

ERROR  | Cannot initialise: config component failed to start.

ERROR  | CFUtils::raiseEvent: event 13 (CAFEVENT_ERROR) raised: Cannot initialise: config component failed to start. 

 

2. Above Error's occurs if there is a problem with CCNF directory . Check the CCNF directory location. 

2.2.jpg

3. At the time of installing the ITCM domain manager in High Availability Mode gives option to store the common component directories in Shared drive . Check if Shared drives are properly attached in My Computer . 

3.1.jpg

4. Added Shared drives . 

3.2.jpg

5. Shared drive showing common component directories including CCNF in below pictures

4.1.jpg

6. Files in CCNF directory. 

5.1.jpg

7. If still caf service not working after adding the shared drives , Run ActiveManagerNode.bat file to make this Node Active .

5.2.jpg