Caf Service not working after deploying agent from Infrastructure deployment wizard.pipe not open error in caf service log.

Document ID : KB000096799
Last Modified Date : 10/09/2018
Show Technical Document Details
Issue:
ITCM all agent  deployed from domain manager infrastructure deployment wizard . Agent installation is successful but caf service not starting . 
TRC_CF_CAF_SERVICE log shows below error. 
CCFPlugin::SendMessage: ccsmagt: pipe not open
Environment:
ITCM - All Versions
Resolution:
1. Go to services on agent machine and check the properties of Common Application frame work . 
In below screenshot we can see that its pointing to wrong path. 
User-added image

2. Go to Registry Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\caf
check imagepath value . In below screenshot we can see that Image path is not pointing to actual 
agent installed folder. 

User-added image

3. This has to be changed to actual path where agent is installed. Check if the agent is installed in C drive or D drive. 
copy the path : For Example if agent is installed in C drive 
C:\Program Files (x86)\CA\DSM\Bin & add caf.exe to path 

"C:\Program Files (x86)\CA\DSM\Bin\caf.exe"
As shown in below picture. 

User-added image


4. Execute Caf start . Check if all plugins are running.  
Additional Information:
Note:
Another solution to this issue is to upgrade Symantec Enterprise Management Server to the latest version of 14.2. The Symantec agent modifies CA's service because its application CleanUpUtility.exe which is used for removing older versions of Symantec prior to installing its new agents thinks CA's Framework Service Binary is part of Symantec and makes modifications to its PATH variable thus breaking it. Please see Fix ID: 4148344 in the following article from Symantec:
https://support.symantec.com/en_US/article.INFO5072.html