CAF service is missing from agents

Document ID : KB000097663
Last Modified Date : 23/05/2018
Show Technical Document Details
Issue:
Computers stopped daily registration and upon further investigation found that the CAF service was missing on these agent computers. How do I correct this issue?
Environment:
All versions of CA Client Automation
Cause:
This issue may happen if the CAF service has been deleted from the following registry key
HKEY_LOCAL_Machine\System\CurrentControlSet\Services\CAF 

(OR)

The CAF service has been uninstalled using the 'caf uninstall' command.
 
Resolution:
To restore the CAF service run the following commands:
caf install
caf start