CABI SSL

Document ID : KB000123209
Last Modified Date : 19/12/2018
Show Technical Document Details
Issue:
Customer installed a new instance of CABI v6.30 and is using cabi_external. CABI is running fine using port 8080 but they need to configure HTTPS access to CABI.
Environment:
- UIM v8.5.1
- CABI v6.3x
Cause:
- Documentation unclear
Resolution:
How to setup HTTPS access to CABI 

1. Obtain a real certificate (not a self-signed certificate), from a certificate vendor, e.g., Verisign, Digicert, GoDaddy etc. 
2. Obtain the given vendor's instructions on how to install the certificate for Tomcat 
3. Then follow the UIM documentation on how to setup CABI to use SSL...which includes steps to configure UMP for HTTPS.

How to configure the CABI server for https:

https://docops.ca.com/ca-business-intelligence/6-4-3/en/administration/configuring-ssl 

Then follow: 

https://docops.ca.com/ca-unified-infrastructure-management/8-5-1/en/installing-ca-uim/ca-business-intelligence-with-ca-uim/installing-and-upgrading-ca-business-intelligence-jasperreports-server-with-ca-uim/install-or-upgrade-for-an-external-ca-business-intelligence-jasperreports-server#InstallorUpgradeforanExternalCABusinessIntelligenceJasperReportsServer-ConfigureCABIServertoUseHTTPS