CABI 6.2 Test Connection fails if SDM is running on a non-English OS

Document ID : KB000045831
Last Modified Date : 23/05/2018
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Issue:

When we define the datasource for Service Desk Manager (SDM) for CABI 6.2.0 by following the "Step 3: Configure CABI JasperReports® Server r6.2.0 for CA SDM", the connection test fails with an error message "Connection failed Show Details".  When clicking on the link "Show Details", a blank screen comes up as shown below. You may also see error messages including the words "MappableContainerException" and "MalformedInputException".

error.jpg

Environment:
This issue occurs when SDM is installed on a Windows server, and the server OS locale is set to a value other than English (e.g. Japanese). The problem may also occur if the database charset has been modified from its' initial settings to accommodate non-English characters, or if the database is installed on an OS with a non-English locale.
Cause:

Non-English OS locales use a different character set and input format than the English locale. JasperReports Server is designed to integrate with Service Desk Manager on an English-locale OS, and encounters the "MalformedInputException" as it fails to process the data.

Resolution:
Modify the locale settings for the Windows server on which SDM is installed, setting the locale to English. You may need to fully restart the server on which SDM is installed after making this change.
Additional Information:
For more information on the languages supported by JasperReports Server, please see the following link.
CA Business Intelligence JasperReports® Server - 6.2.0 - Supported Languages