CA Workload Automation DE server down

Document ID : KB000009068
Last Modified Date : 14/02/2018
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Issue:

In order to apply patches, the operating system (OS) was brought down.

Then, when the OS returned back to operational, we could not start the DE server until the cold mode was used.

Cause:

The cold start was in needs because, apparently, the DE database data lost their integrity. 
It could happen due to the connection to the MS SQL server was lost when DE server had not yet finished its closing transactions, for example: 

20171219 20:19:30.177 [trace:afm] [INFO] WSS_cmd_executor_326: <-- CTOKEN(D1000009) SUBSYS(AC19D4411D4C) 
SUBSCRIB STOKEN(L000000009) STOP 
... 
20171219 20:20:37.040 [relationaldatabase] [ERROR] DM.Appl.HP_SD_EVENTS.1985: rollback SQLCode: 0 SQLState: null Message: 
The connection is closed. 

followed by an array of the database connectivity related exceptions, e.g. 

20171219 20:20:42.422 [relationaldatabase] [ERROR] WS: Exception: 
Unable to access database 'WA_PRD' because its replica role is RESOLVING which does not allow connections. Try the operation again later... 

Resolution:

In order to avoid a trouble like this, keep the database alive till the moment when DE server has stopped completely.

NB. In case DE server operates under MS Windows, sometime a Windows service is shown as stopped while the actual process is still running - check Windows Task Manager to make sure that the 'service.exe' process related to DE application is not presented on the list (you might have more than one service.exe running but the properties of the process will show belong to what application it is).