CA Workload Automation AE (AE) Application Server service does not stay up.

Document ID : KB000007935
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

The WAAE Application Server process stops soon after the start. The following error message is repeatedly logged in the as_server log ($AUTOUSER/out/as_server.ACE): 

ERROR: [0x070a8b70] ConfigUtil::XMLToConfigElement::handleError : Error parsing xml data line : 0 , char : 0 , message : (null)

ERROR: [0x070a8b70] ConfigUtil::XMLToConfigElement::xmlToConfigElement : there where errors when parsing xmlfile [ xmlfile : /opt/CA/WorkloadAutomationAE/autouser.ACE/eiam.server.config ]ERROR: [0x070a8b70] ConfigUtil::xmlFile2ConfigElement : unable to parse xml file [/opt/CA/WorkloadAutomationAE/autouser.ACE/eiam.server.config] ConfigUtil::XMLToConfigElement::xmlFileToConfigElement() returned error

Result::debug: [ConfigReader::loadConfigFromFile: unable to load xmlfile [/opt/CA/WorkloadAutomationAE/autouser.ACE/eiam.server.config]]

ConfiguratorImpl::init_internal: unable to load configuration

 

Environment:
All Workload Automation AE 11.3.6+ version supported environments
Cause:

While using the external CA Embedded Entitlement Manager (EEM) security, the file "$AUTOUSER/eiam.server.config" is either missing or has insufficient permissions.

Resolution:

If the file $AUTOUSER/eiam.server.config is found to be missing, copy over from one of the other WAAE servers or environments of the same version.

Correct the file ownership and ensure the read permissions are allowed to the user who starts the service(s).

Restart the application server: 

# unisrvcntr start waae_server.ACE

WAAE Application Server (ACE)                              [  OK  ]

Executed waae_server.ACE start...................................OK

#