CA UIM 8.47 - Can I install Java 8

Document ID : KB000126190
Last Modified Date : 04/02/2019
Show Technical Document Details
Question:
Within the following link:
https://docops.ca.com/ca-unified-infrastructure-management/9-0-2/en/installing/product-compatibility/ca-uim-compatibility-matrix
...under the Component support matrix,  Java 7 is the supported version. Is it possible to go ahead and upgrade the server to Java 8, while leaving Java 7 on the server? Perhaps there is a way to hard code UIM to use Java 7 when Java 8 is also installed?
Environment:
UIM 8.5.1
 
Answer:
So, as long as Java 8 is installed somewhere else, that is fine.
Nimsoft will use the java folder under its installation directory: "/jre/jre###" The configuration for this is in the /robot/controller.cfg file.
You can also look at: NIM_JRE_HOME and/or NIM_JRE_HOME_1_8 in the IM console > Controller configuration > Environment tab.
All of the probes and system probes will reference those java folders.

Be mindful of UIM upgrades though.  The installers may pick up the java from the Operating System $PATH/%PATH%.