CA UIM / CABI - Office365 CABI Dashboard not populating data, metrics appear blank

Document ID : KB000112754
Last Modified Date : 03/09/2018
Show Technical Document Details
Issue:
- Data not displayed for office 365 probe via CABI UIM Summary Dashboard. 
- Open the CABI Summary Dashboard -> monitored technologies selected Office 365 -> Dashboard loads correctly but does not display any metrics for the office 365 probe. 
- Metrics are configured and being gathered by the probe. Metrics are visible via the SLM portlet for the office 365 probe. 
Environment:
- UIM version 8.51 
- cabi probe version 3.20 
- ump_cabi package version 3.20 (deployed to the UMP robot) 
- uim_core_dashboards version 2.40 
- uim_cabi_health_report_pack version 1.20 
- uim_unified_reporter_pack version 1.02 
- All servers are Win Server 2012 R2 
- Windows Authentication is being used. 
- UIM database SQL Server 2014 
- office 365 probe version 1.00 (this probe runs on the same robot as cabi) 
Resolution:
We found that the ci_defn_pack was missing from the primary hub. 

1. Deploy ci_defn_pack (version 1.39 or later) to the Primary hub. 

2. Deactivate the nis_server and office365 probes. 

3. Reactive the nis_server and office365 probes. 

4. Open your browser and clear browsing cache. 

5. Login to the UMP Console with the administrator account, go to the CABI UM Summary Dashboard and drill down to the office365 via Monitored Technologies. 

There's more information on this pacakge under the probes prerequisites here: 

https://docops.ca.com/ca-unified-infrastructure-management-probes/ga/en/alphabetical-probe-articles/office365-office-365-monitoring/office365-office-365-monitoring-release-notes#office365(Office365Monitoring)ReleaseNotes-Prerequisites