CA UCM Harvester service will not start after new installation.

Document ID : KB000006829
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

On a fresh installation of UCM 4.3, you do not see that the Harvester service will start.  You also find the following in the Harvester.log file:

WARN  2017-05-16 12:36:04,985 [ConfigFile] Failed to read in configuration: does not exist: C:\CA\VoIPMonitor\Harvester\..\bin\vcAgentConfig.xml
WARN  2017-05-16 12:36:04,992 [ConfigFile] Failed to read in configuration: does not exist: C:\CA\VoIPMonitor\Harvester\..\bin\vcAgentConfig.xml
WARN  2017-05-16 12:36:04,993 [ConfigFile] Failed to read in configuration: does not exist: C:\CA\VoIPMonitor\Harvester\..\bin\vcAgentConfig.xml
ERROR 2017-05-16 12:36:04,993 [ConfigReloader] *** Failed to read the config file ***.
ERROR 2017-05-16 12:36:04,994 [Harvester] Failed to load config file

Other services may not start as well.

 

Environment:
Windows 2012 R2UCM 4.3
Cause:

The Monitor port has not been configured as part of post-installation.

Resolution:

In order to start the harvester service, the Console need to be configured post-installation.  Connect to the browser on the server: http://localhost/ucmonitor/default.aspx.  It should take you to the Administration->Console->Settings page.  Fill out the entries on this page, making sure to choose either "No Monitoring" or the monitoring NIC for the Monitor under the Console IP Configuration section.  Then choose "Save".  The services should the start up automatically.

UCM Config.PNG