CA Strong Authentication server does not start with backup database

Document ID : KB000067862
Last Modified Date : 01/02/2019
Show Technical Document Details
Introduction:

Issue:

CA Strong Authentication server is not starting up when primary DB is down and backup DB is up.

I have configured both primary database and secondary database for CA Strong Authentication installation. When primary database is up, the server is starting without problem but when primary database is down and secondary database is up, CA Strong Authentication server is not able to start up.

Environment:

Products: CA Strong Authentication Server - version 8.1

Database: Any supported database

 

Cause:

The factory settings of CA Strong Authentication server is to start with Primary DB only. In the startup log you can see the configuration of "StartWithAnyPool" is set as 0 by default.

00WFMAIN - -------------------------------------------------------------------

00WFMAIN - Listing : [arcot/db/dbconfig]

00WFMAIN - -------------------------------------------------------------------

00WFMAIN - arcot/db/dbconfig/DbType..................... : [oracle]

00WFMAIN - arcot/db/dbconfig/EnableBrandLicensing....... : 1

00WFMAIN - arcot/db/dbconfig/StartWithAnyPool........... : 0

00WFMAIN - -------------------------------------------------------------------

 

Resolution:

The configuration parameter "StartWithAnyPool" needs to enabled. This enables CA Strong Authentication to start with the backup database when the primary database is unavailable.

Set/add below parameter in [arcot/db/dbconfig] section of <ARCOT_HOME>/conf/arcotcommon.ini

StartWithAnyPool=1

 

Additional Information:

The CA wiki page which defines this configuration parameter can be found here : Parameters Used by CA Strong Authentication Server

Instructions:
Please Update This Required Field