CA Spectrum OneClick Tomcat process does not start

Document ID : KB000117607
Last Modified Date : 16/10/2018
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Issue:
After restarting the CA Spectrum OneClick process, no users can login.  The tomcat log file ($SPECROOT/tomcat/logs/stdout.log on windows or $SPECROOT/tomcat/logs/catalina.out on linux) stops updating after showing alarm.web.model.gatherpoolsize:


Oct 15, 2018 15:04:32.505 (localhost-startStop-1) (GAPM) - GAPM.user preload: 73ms

Oct 15, 2018 15:04:33.413 (localhost-startStop-1) (ALARMS) - Alarm fire timer scheduled at: 10000
Oct 15, 2018 15:04:33.414 (localhost-startStop-1) (ALARMS) - alarm.web.model.gatherpoolsize : 5

No user can log into OneClick.
Cause:
There is a hung CORBA thread connecting the SpectroSERVERs.
Resolution:
You need to clear up all threads by stopping all SpectroSERVER and processd services on all SpectroSERVER machines.  Stopping the SpectroSERVER process only does not resolve the issue. You need to stop all SS and processd on all SpectroSERVER machines.  Once that has been completed, stop and restart the OneClick tomcat process on the OneClick server.