CA Spectrum install fails unable to connect to SRAdmin

Document ID : KB000056456
Last Modified Date : 06/12/2018
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Issue:

CA Spectrum installation fails with the following error:

"Unable to connect to CA Spectrum Remote Administration Daemon (sradmin)

You can either install sradmin now or if you already have it installed you can start the service and try again.

Click Install to proceed with installing CA Spectrum Remote Administration Daemon.

Click Cancel to go back and try again."

However, prior to starting the installation of Spectrum, SRAdmin was installed successfully but now is not running.

Cause:

A possible root cause is that there is another process using TCP port 46517 used by SRAdmin. To verify, run the following command as the root user on Linux or Solaris to check which process may be running using port 46517:

netstat -anp | grep 46517

On Windows, open a bash shell by running "bash -login" and run the following command to check which process may be running using port 46517:

netstat -ano | grep 46517

Resolution:
If there is another process using port 46517, stop the process and manually start SRAdmin and then restart the installation.