CA Service Desk Manager registers Auto-close activity in English date format

Document ID : KB000004236
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

CA Service Desk Manager (SDM) registers Auto-close activity in English date format.

This is easily identified in the Activity Log of a ticket which had a status changed to Resolved (for example) and has the auto-close functionality configured.

Environment:
This occurs to the localized releases of SDM.CA Service Desk Manager r12.x, r14.1, r17
Cause:

In localized releases of SDM, it is usual to see the date format set for DD/MM/YYYY HH:mm.

It is expected to see the auto-close date respecting the ticket date format, however, when the variable EXPANDER_FORMAT is not installed, the auto-close message in the Activity Log of the ticket will show the date in the format of MM/DD/YYYY HH:mm.

Resolution:

In localized releases of SDM, it is usual to see the date format set for DD/MM/YYYY HH:mm.

It is expected to see the auto-close date respecting the ticket date format, however, when the variable EXPANDER_FORMAT is not installed, the auto-close message in the Activity Log of the ticket will show the date in the format of MM/DD/YYYY HH:mm.

 

Resolution:

To fix this behavior, it is necessary to install the EXPANDER_FORMAT variable.

As this variable is not present in Options Manager, it needs to be manually added via pdm_options_mgr command line utility.

 

1. For Conventional installations of SDM:

The following command needs to be executed on each of the servers:

pdm_options_mgr -s EXPANDER_FORMAT -v DD/MM/YYYY -a pdm_option.inst

pdm_options_mgr -s EXPANDER_FORMAT -v DD/MM/YYYY -a pdm_option.inst -t

It is required that SDM services be recycled so the changes take effect.

 

2. For recommendations on Advanced Availability installations of SDM, refer to the following document: 

TEC1448647 - Options in Advanced Availability (AA) environment

Additional Information:

Setting EXPANDER_FORMAT is not valid for tickets which already have the incorrect date format registered in the Activity Log.

The following document explains other affected area of SDM when using EXPANDER_FORMAT:

TEC479888 - I have modified the web.cfg file for date format but still Notifications sent carry the default format?