CA Service Desk Manager 17.0 web interface is not working in my multi-nic card environment

Document ID : KB000008593
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

The CA ServiceDesk Manager is installed, the ServiceDesk service is running and after installation we are able to  access the application via the web interface. 

Now, after restart the server and the ServiceDesk service the web access fails !

The login screen appears and after introduce the right credentials the screen turns white and nothing happens.

Environment:
ServiceDesk Manager 17.0
Cause:

The problem may be related to ServiceDesk server platform having 2 NIC cards and is already fixed in r17.0 but you still need to define the related environment variable to allow the fix to initiate.

 

Resolution:

The fix introduced a new NX variable @NX_PICK_FIRST_IPV4.
If this variable is set to “yes”, then Service Desk will use internally the first IP address it finds in the list returned from the getaddrinfo Microfost API call.

This option can be installed by running the following command from the Command Prompt on the Primary server machine:

"pdm_options_mgr -c -s PICK_FIRST_IPV4 -v yes -a pdm_option.inst "

To avoid losing the change when you run pdm_configure, please run the above command with the '-t' flag as follows:

"pdm_options_mgr -c -s PICK_FIRST_IPV4 -v yes -a pdm_option.inst -t "

Note:
For Conventional environment, for each secondary Service Desk server you have configured, please manually add or update the NX variable above in each secondary Service Desk server machine within its NX.env file located under $NX_ROOT directory.
A Service Desk product recycle is normally needed for the new NX variable to take effect.

For Advanced Availability environment follow the documented steps to add a new environment variable.

 

Additional Information:

See  TEC1448647 Implementing NX environment variable options in an Advanced Availability (AA) environment