CA Service Catalog Form Table disappears on submit

Document ID : KB000111892
Last Modified Date : 22/08/2018
Show Technical Document Details
Issue:

Using a table component in one of the forms in the Catalog.
When the user submits the form the table data disappeared.
Environment:
Windows
Cause:
Checkbox not 'checked' in fron of (each) row.
Resolution:
In the Catalog UI, on the form, per table processed you can add a row.
Hit the '+' sign, populate the fields in the row and hit 'save' per row.
To keep the row(s) in the form/request, you have to check the checkbox in front of each row.
Only then, the 'add to cart' or 'check out' or 'submit' will keep the rows in the request.