CA Service Catalog and PAM integration (Disk full) not working properly.

Document ID : KB000009105
Last Modified Date : 14/02/2018
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Issue:

After a restart of CA Service Catalog(SC) and/or PAM services, the SC<>PAM integration does not function anymore.

For SC-Requests, the corresponding PAM-process does not get fired.

In SC/admin/config/PAM, the Test-button ends in error.

Environment:
WindowsSC R14.1 SDM 14.1 PAM 4.3 EEM 12.51
Cause:

After further researching, it appeared that the SC C-Drive got filled up for 100%

Which caused SC not to be able to start properly.

Resolution:

As you then can check, see and do to resolve the problem situation(SC not connecting to PAM properly with SC-test button):

1. Disk drive C: got filled

2. First we deleted from %USM_HOME%\logs several large .hprof files

3. Then after a SC-service restart, C-drive got filled rapidly there after

4. As it appeared, %USM_HOME%\logs\jms-data folder contained about 120GB of tx_nnnn.tmp files

5. We removed those

6. And we removed the jms-data\db.redo and db.data files then too

7. Next step is to restart SC-service

>> Note: Because of the rebuild, it may take longer for Service Catalog to completely startup. 

8. SC/admin/config/PAM>Test now processed successfully.

9. And SC-requests got their PAM=process started (although slow)

10 The slowness (for both SC and PAM) might be caused by the 'huge startup' situation now.

11 Give the system the time to get in balance.