CA Risk Analytics - Rules has been created but it is not appearing in the Reports

Document ID : KB000112496
Last Modified Date : 30/08/2018
Show Technical Document Details
Introduction:
The Rule has been created as per the requirement, based on the Instructions provided in the CA Risk Analytics administration document, using the right expressions.

But still the Rule doesn't appear in Reports.
Question:
Why the Rules created doesn't appear in Reports.
Environment:
Production
Answer:
Once the Rule is created as per the requirement and according to the instructions provided in CA Risk Analytics administration manual.

Please make sure you "Migrate to Production", so that the Rule will become Active.

How to Migrate to Production.

1) Login to admin console.
2) Click on "Organizations" tab.
3) Search for the Organization and click on Organization name.
4) You will receive the details page, click on "Risk Engine" tab.
5) Once you click on "Risk Engine" tab, in the left panel, you will see a list of options, under "Migrate to Production" category, you will have the option "Migrate to Production".
6) Click on the option, and select the "Ruleset" under which you have created the Rule, and click on Migrate.

Please find the screenshot below for reference.

User-added image

Once to perform Migrate to Production, please perform the below changes to Validate.

Perform the Step 1) to 4) mentioned above and under "Rules Management" category.
Click on "Rules and Scoring Management".

In the screen you should be able to see the newly created Rule and the checkbox under Enable should be checked.