CA Process Automation and BigIP F5 supported versions

Document ID : KB000112023
Last Modified Date : 23/08/2018
Show Technical Document Details
Introduction:

The current release of BigIP F5 LTM as of this KB article publication is 13.1.
We have had numerous questions on when CA Process Automation will support the current releases.

Question:
The CA Process Automation documentation currently states the supported version of BigIP F5 LTM as 11.6. 
Can we use version 12 or 13?
Answer:
The very simple answer is no. 
Versions 12 and 13 have not been tested at all and we have had issues around agents being deployed in an environment using F5 LTM 12.1 and 13.1.
The currently supported version is 11.6, and the newer versions handle traffic management a bit differently. An iRule is no longer in a typical setup of these versions.
Although the traffic between orchestrators may appear to function normally when using the newer releases, from what we have seen there is an issue with agent communication. 
As these versions have not been tested, we cannot know what other problems could arise with soap or REST calls, or integrations with other CA products.