CA PPM URL not loading on Chrome

Document ID : KB000095672
Last Modified Date : 14/05/2018
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Issue:
After a data refresh from production to development, we are unable to access our development URL using Google Chrome.
Environment:
CA PPM - All Versions (PPM SAAS and PPM ON PREMISE)
Cause:
This problem is typically caused by old data in the browser cache.
Resolution:
Clear the cache in the browser, close it, then re-open it and test the URL again.  
Additional Note:  Also try a Chrome "incognito" window  - this uses a blank cache, and no add-ins.