CA PPM Upgrade fails with error on DWH_INV_SECURITY.xml

Document ID : KB000005089
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

CA PPM Upgrade to 14.4 or higher version fails when upgraded from 14.3.0.9 (14.3 Patch 9) and fails with error in install.log

 

Process - table: DWH_INV_SECURITY.xml 

11/16/16 9:51 PM (admin) com.ca.clarity.jdbc.oraclebase.ddc: [CA Clarity][Oracle JDBC Driver][Oracle]ORA-01702: a view is not appropriate here 

11/16/16 9:51 PM (admin) at com.ca.clarity.jdbc.oraclebase.dde3.k(Unknown Source) 

11/16/16 9:51 PM (admin) at com.ca.clarity.jdbc.oraclebase.dde3.a(Unknown Source) 

11/16/16 9:51 PM (admin) at com.ca.clarity.jdbc.oraclebase.dde3.executeBatch(Unknown Source) 

11/16/16 9:51 PM (admin) at com.ca.clarity.jdbc.oraclebase.dde5.executeBatch(Unknown Source) 

11/16/16 9:51 PM (admin) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) 

11/16/16 9:51 PM (admin) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) 

11/16/16 9:51 PM (admin) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) 

11/16/16 9:51 PM (admin) at java.lang.reflect.Method.invoke(Method.java:497) 

11/16/16 9:51 PM (admin) at org.logicalcobwebs.proxool.ProxyStatement.invoke(ProxyStatement.java:68) 

11/16/16 9:51 PM (admin) at org.logicalcobwebs.cglib.proxy.Proxy$ProxyImpl$$EnhancerByCGLIB$$25b04b8e.executeBatch(<generated>) 

11/16/16 9:51 PM (admin) at com.niku.dbtools.Utilities.executeAndCommitSql(Utilities.java:2736) 

11/16/16 9:51 PM (admin) at com.niku.dbtools.DriverApp.apply(DriverApp.java:1493) 

11/16/16 9:51 PM (admin) at com.niku.dbtools.DriverApp.installSchemaDriver(DriverApp.java:713) 

11/16/16 9:51 PM (admin) at com.niku.dbtools.Utilities.run(Utilities.java:1862) 

11/16/16 9:51 PM (admin) at com.niku.dbtools.Utilities.main(Utilities.java:975) 

11/16/16 9:51 PM (admin) SQL Text: 

11/16/16 9:51 PM (admin) CREATE INDEX DWH_INV_SECURITY_N2 ON DWH_INV_SECURITY ( USER_UID, GLOBAL_VIEW_RIGHT, PERMISSION_KEY ) TABLESPACE US51751tDWH_PPMDWH_INDX 

11/16/16 9:51 PM (admin) CREATE INDEX DWH_INV_SECURITY_N3 ON DWH_INV_SECURITY ( USER_UID, GLOBAL_VIEW_RIGHT, INVESTMENT_KEY ) TABLESPACE US51751tDWH_PPMDWH_INDX 

11/16/16 9:51 PM (admin) CREATE INDEX DWH_INV_SECURITY_N4 ON DWH_INV_SECURITY ( PERMISSION_KEY, SYS_OP_C2C(USER_UID) ) TABLESPACE US51751tDWH_PPMDWH_INDX 

11/16/16 9:51 PM (admin) CREATE INDEX DWH_INV_SECURITY_N5 ON DWH_INV_SECURITY ( INVESTMENT_KEY, SYS_OP_C2C(USER_UID) ) TABLESPACE US51751tDWH_PPMDWH_INDX 

11/16/16 9:51 PM (admin) Note: Foreign Keys and Triggers have been enabled 

11/16/16 9:51 PM (admin) DBDriver failed to install! 

Environment:
CA PPM 14.4 & higher
Cause:

The DWH security design was changed from table to view at this patch and hence its giving the error.

Resolution:

If you on CA PPM 14.3.0.9 (14.3 Patch 9) then before upgrading to 14.4 or higher version, please apply 14.3.0.10 (14.3 Patch 10)