CA PPM Install/Upgrade Fails During Pre-Checks On Data Warehouse, even when Data Warehouse Is Not Being Used

Document ID : KB000006655
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

CA PPM Install/Upgrade Fails During Pre-Checks On Data Warehouse, even when Data Warehouse Is Not Being Used. 

Environment:
CA PPM 14.2 onwards
Cause:

Considering a CA PPM environment, wherein Data Warehouse is not being used and hence does not have the required Data Warehouse server settings enabled / updated in CSA

However, in CA PPM application, under the System Options >> Data Warehouse Options, if the field "Entity for Fiscal Periods", is associated to the entity, during the upgrade, the system will carry out a pre-check, confirming the connectivity to the Data Warehouse database.

Since, the Data Warehouse settings are not enabled in the CSA, the upgrade process fails because it checks for Data Warehouse settings 

Resolution:

In order to upgrade under such a situation, the following is the recommended approach:

  • Login to CA PPM and navigate to Administration >> System Options >> Data Warehouse Options
  • Under the Data Warehouse Options, remove the entity associated to the field - "Entity for Fiscal Periods"
  • Click on Save
  • Re-do the CA PPM Upgrade
Additional Information:

Note: If you are not using Data Warehouse you will not need to save in the application also.

 

1.jpg