CA PPM: Database is unavailable in CSA

Document ID : KB000112429
Last Modified Date : 29/08/2018
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Issue:
The CA PPM database for MSSQL and Oracle is showing up as unavailable.
Cause:

The error is apparent in the nsa-ca, app-ca, or bg-ca logs.

This can be due to one or more of the following reasons:

1. The database does not exist on the database server
2. The JDBC connection descriptor is invalid
3. The database server is down.
 

Resolution:

Check with the DBA team to make sure the following steps have been performed:

1. The Niku database has been created/imported.

2. The CSA > Database page needs to have valid properties provided.

-Hostname
-Database user
-Database password

If a JDBC URL is being used, make sure the connection descriptor is valid.
In Oracle 12c+, the JDBC URL string will need to be modified to use the service name instead of the SID.