CA PPM: Configure option not available on allocations detail view

Document ID : KB000106020
Last Modified Date : 11/07/2018
Show Technical Document Details
Issue:
We have a problem where when one user goes to Home > Resource Management, then Allocations Tab, selects a user, goes to the Allocations Tab, then changes the dropdown to "Detail" - they no longer have the "Configure" link in the settings dropdown within that view.
Environment:
CA PPM - All Versions
Resolution:
To resolve this, the user's view needs to be reset to default, which should restore the "configure" option.  Here are the steps to reset that user's view to default:

1. Use IE as the browser
2. Login to CA PPM as a user who has the Configure Option, and navigate to the working Portlet then click the Configure icon to open up the modal dialog.
3. Press F12 to bring up diagnostic/dev tools, click on Network tab, click on the ‘Play’ (green arrow) icon to start capture.
4. In the UI go from the Layout tab of the configure dialog to General tab.
5. In the F12 network window, right-click the row for the URL that was first requested and select Copy URL from the menu
6. Change in the URL:
From
http://myserver/niku/nu?uitk.vxml=1&action=
To
http://myserver/niku/nu#action:
7. Press F12 to stop / close the Dev tools window. Logout of CA PPM
8. Now send this url to your problem user
9. Have that user close all IE windows and then open a new browser window
10. Have the affected user paste the modified URL into the browser window and click the Enter key.
11. When prompted for a login, the user should enter their credentials. This will now bring the user to the Configure:General page.
12. Click on restore Defaults