CA PPM admin commands throw heap error

Document ID : KB000009241
Last Modified Date : 14/02/2018
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Issue:

The "admin" commands can throw heap errors, especially during add-in installations, when there is no enough memory for them to work on, and when dealing with large data sets. A sample of the error that can be throw is provided below:

1/5/18 8:17 AM (admin)         at com.niku.union.xml.dom.DOMWalker.traverseIntern(DOMWalker.java:92)

1/5/18 8:17 AM (admin)         at com.niku.union.xml.dom.DOMWalker.traverse(DOMWalker.java:36)

1/5/18 8:17 AM (admin) ERROR 2018-01-05 08:17:31,952 [main] union.service rollback exception

1/5/18 8:17 AM (admin) java.lang.OutOfMemoryError: Java heap space

1/5/18 8:17 AM (admin)         at java.util.ArrayList.toArray(ArrayList.java:407) 

 

Look for these errors in either the terminal or the admin.log.

Environment:
CA PPM All Versions
Cause:

The error in heap is due to inadequate amount of JVM allocation. 

Resolution:

Open admin.bat using a text editor and look for a line such as the below:

set PROGRAM_ARGS=-Djava.net.preferIPv4Stack=true -Dfile.encoding=UTF-8 -Xmx512m -Dniku.home="%NIKU_HOME%" -Dforehead.conf.file="%NIKU_HOME%\bin\admin.forehead" com.werken.forehead.Forehead -installDir "%NIKU_HOME%".

 

Here change the argument -Xmx512m to -Xms4096m -Xmx4096m.

 

Please note that, to increase the allocated memory to 4 GB, the server that would be executing this command, would need to have that much free memory available.